Duyuruyu Kapat
Facebook Gözat
Twitter Gözat

xp, apache, php-4.2.2

Konu, 'PHP' kısmında sisqo tarafından paylaşıldı.

  1. sisqo

    sisqo Yeni Üye

    Kayıt:
    13 Ağustos 2002
    Mesajlar:
    1
    Beğenilen Mesajlar:
    0
    Merhaba
    1-2 gün önce xp ye apache 1.2.6 ve php-4.2.2 kurdum fakat gördümkü php-4.2.2 ye eklenen bir güvenlik ayarından dolayı include ettiğim sayfalarda hata alıyorum. Bu hatayı php.ini den include_path ve diğer ayarları deneyerek iptal etmeye çalıştım ama olmadı acaba bu konuda çözümü olan arkadaş varmı?

    Warning: Failed opening '' for inclusion (include_path='.;c:\php4\pear') in c:\apache\htdocs\index.phtml on line 46
     
  2. Sahin

    Sahin Daimi Üye

    Kayıt:
    28 Mayıs 2002
    Mesajlar:
    8,943
    Beğenilen Mesajlar:
    0
  3. turker

    turker Agresif Üye

    Kayıt:
    19 Temmuz 2002
    Mesajlar:
    5,988
    Beğenilen Mesajlar:
    0
    ana dizin--->
    index.php
    data dizini----->
    a.php
    b.inc

    index php--->
    <?php
    ........
    .....
    include("data/a.php");
    .....
    ?>

    a.php---->
    <?php
    ....
    ....
    include("data/b.inc");
    ...
    ?>

    b.inc------>
    sallıyorum işte
     
  4. mkarabulut

    mkarabulut Misafir

    Bu hataya ben sadece 1 durumda karşılaştım ,
    o da include ettiğin dosya yerinde yoksa, PHP onu bir de include path ile belirtilen yerde arıyor, orada da bulamayınca bu hatayı veriyor.

    Yani sorun :
    <?
    include("./deneme.php");
    ?>

    deneme.php dosyası yerinde yok ise bu hatayı verir.